Linux运维-陈雷雷


华为HCNP_08.路由冗余和备份_浮动静态路由配置

admin 2019-05-04 1113浏览 0条评论
首页/正文
分享到: / / / /

路由冗余和备份_浮动静态路由

浮动路由是指,在一条链路down了之后另一条路由接替工作,从而保证网络设备稳定性

配置过程:

首先基本配置 配置号拓扑图中标记的IP地址。

再配置路由信息,ip地址配置过于简单,不在截图详解了

配置过程建议 关闭 info信息

undo in en

主要配置:

R1

[R1]ip route-static 172.16.1.0 24 12.1.1.2

R2

[R2]ip route-static 192.168.1.0 24 12.1.1.1

两个路由器 配置这两条路由后 双方主机就可以进行通信了,如果不通就要排查问题了

但是这个通信仅限于单链路通信,日常企业中 用到这种单出口的也不少。

可以通过 dis cu 查看当前配置:[静态路由优先级为 60 ]

[R1] dis cu                 ---------------查看配置
interface Ethernet0/0/0
 ip address 192.168.1.1 255.255.255.0
#
interface Ethernet0/0/1
 ip address 21.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/0
 ip address 12.1.1.1 255.255.255.0
#
ip route-static 172.16.1.0 255.255.255.0 12.1.1.2

关闭21.1.1.0 的接口 测试网络是否互通

关闭命令:

shutdown

启动命令:

undo shutdown

测试:

PC>ping 172.16.1.2     关闭链路后无法通信了

Ping 172.16.1.2: 32 data bytes, Press Ctrl_C to break
Request timeout!
Request timeout!
Request timeout!
Request timeout!
Request timeout!

接下来配置静态浮动路由,作用就是在关闭一条链路(企业中是一条链路down了)后也可以无缝切换到另一条链路,确保网络正常

冗余路由配置:

ip route-static 172.16.1.0 255.255.255.0 12.1.1.2

ip route-static 172.16.1.0 255.255.255.0 21.1.1.2 preference 55

注意静态路由默认优先级为60 越小越优先,在配置多条链路想让某个链路更优先,可以通过 preference[数值]来决定路由默认走哪条链路

配置完成后,可以尝试切换链路

切换方式就是进入一条接口 使用 shutdown 命令关闭

需要开启的话 使用 undo shutdown

同时,查看路由表,路由表中只会存在最优路由,也就是优先级最低的那条,如果那条路由down了,会自动切换到另一条

静态浮动路由配置结束,学会了没,伙计们??

实验案例文件下载: 静态浮动路由实验.zip

最后修改:2019-05-04 12:39:56 © 著作权归作者所有
如果觉得我的文章对你有用,请随意赞赏
扫一扫支付

上一篇

发表评论

评论列表

还没有人评论哦~赶快抢占沙发吧~

博客信息

  • 文章数目 80
  • 标签数目 232
  • 运行天数
  • 最后活动

广告



文章目录